Update Masternode from 3.2.8 to 4.0.0

From DeFiChain-Wiki
Revision as of 00:39, 12 November 2023 by ChrisFor (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

(this applies to Linux and has been tested on Debian 11)

Prerequisites

  • Make sure you have at least glibc 2.29 available as explained here
    • Run ldd --version in order to find out your current version
    • Run lsb_release -a to find out your current linux release
    • (e.g. you are fine for Debian 11 with glibc 2.31)
  • Download the 4.0.0 archive and its SHA256 hash from the github repo (section Assets)
    • Run wget https://github.com/DeFiCh/ain/releases/download/v4.0.0/defichain-4.0.0-x86_64-pc-linux-gnu.tar.gz
    • Run wget https://github.com/DeFiCh/ain/releases/download/v4.0.0/defichain-4.0.0-x86_64-pc-linux-gnu.tar.gz.SHA256
    • Run sha256sum -c defichain-4.0.0-x86_64-pc-linux-gnu.tar.gz.SHA256 to verify the archive
  • Extract the archive with tar -xvzf defichain-4.0.0-x86_64-pc-linux-gnu.tar.gz

Update

  • Stop your defi service
  • Copy everything from <archive>/bin to wherever your 3.2.8-binaries are
  • Copy everything from <archive>/share to /usr/share
  • Restart your defi service